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Important notes regarding this user manual

In this manual notes of particular importance are presented as follows:

CAUTION
Indicates that equipment may suffer dam-
age or that data loss may occur should the  .
instructions not be followed correctly.

WARNING
Indicates that equipment may suffer dam-
age or that there is a risk of injury to the op-
erator or user should the instructions not be  .
followed correctly.

Conventions 

Term / Symbol Description Example

Logger In this manual the term "logger" 
is used to mean "MSR255“. 

Commands, programs, 
menu items, functions, 
field names

Commands, programs, menu 
items, functions, field names are 
shown in bold.

Record

-> See page -> 5 

•	Reference to further 
	 information
•	Further information
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Safety instructions and warnings

WARNING

•	Read the operating instructions carefully before using the logger or the logger 
software. This will protect you personally and avoid damage to the unit.

•	The logger is a unit for recording and displaying measurement parameters 
and may not be used for safety-related applications.

•	Before using the logger check the unit itself and all cables for visible signs of 
damage and never operate a damaged logger. A damaged logger can endan-
ger operator safety! Should the logger not function perfectly or appear to be 
damaged, send it to MSR Electronics GmbH for repair. 

•	Ensure that no fluids enter the logger's casing.  Fluids cause corrosion  .
damage and short-circuits inside the logger.

•	The logger must never be opened or modified. The manufacturer cannot be 
held liable for damage resulting from use other than that for which the unit is 
intended, or from improper operation of the unit.

•	Never use a logger with a leaking battery. Should a battery leak be detect-
ed ensure that the electrolyte does not come into contact with the skin, the 
eyes or the mouth.  Should this occur, thoroughly rinse the affected area 
with water for at least 15 minutes. Consult a doctor. Do not breathe in any  .
vapours emitted.  Immediately clean the electrolyte from the logger using a 
soft cloth and dispose of the cloth subsequently.

CAUTION

•	Ensure the proper disposal of an obsolete logger, the USB connection cable 
and the mains adapter ->17.
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Operating Instructions

Operating Instructions

MSR 255
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Overview

The logger is a miniaturised universal datalogger for measuring and recording dif-
ferent physical measurement parameters. 
For further information, see data sheets.

The Logger PC program enables users to customise the way in which the log-
ger measures and records data according to their requirements. The integrated 
clock (RTC) allows data from as many loggers as required to be synchronised and 
merged into a single data record. 

USB connection cable CD with PC .
software

Controls

Mains adapterMSR 255

Indicator LED’s
Blue: 	 Record indicator ->29
Red:	 Alarm indicator ->28
Yellow:	 Battery charge indicator ->12

Light sensor
Display
Analogue connections, see delivery for terminal assignment

USB PC-Interface

Push button T1 / T2  

Power supply  .
connector
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Turning the unit on / saving measurement parameters

The storage properties of the logger are determined using the Setup program*.
Control of measurement parameter storage can be either time activated, value 
activated or by pushing the push button.

See also chapter „Logger display / Logger operation“ on page 10.

*Setup is an PC program (see below).
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Off (Factory defaults)
(No data recording, display not available)

Display not available 

Logger display / Logger operation

When the logger is turned off 1 the display cannot be activated using the T1 or 
T2 keys. The display and keys are activated by connecting the logger to a USB 
port or charger 2. The display is operated using keys T1 and T2 (see the dia-
gram "Display and operation").

Logger states 

1

2

Idle state
In the idle state the de-
vice is waiting for start-
up information from the 
PC (setup).

The display turns off 
automatically. It can be 
switched on by means 
of T1 or T2.

Record mode 
Data is recording or the 
device is waiting for start-
up (immediate start, pro-
grammed start time, start 
on key press, external 
start signal)

Recording mode is not 
exited upon ‘stop on key 
press’* (menu 0, T2). 
(*Only possible if acti-
vated in setup)  

The standard display 
appears that was se-
lected under Setup 
> General. This may 
show a single chan-
nel or a multiple dis-
play of 4 measure-
ment parameters.

Display available
(See next page for operation)

Exit record 
mode

Recording has 
been stopped 
from the PC or 
the recording 
period has ter-
minated or the 
memory is full 
(ring memory 
deactivated).

Exit idle state 

PC setup
Entry of start 
info

Exit Off: Connect logger to USB port or 
charger 
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Logger display and logger operation

Menu 0
Record control
State: on/stop by  .
KEY

Channel  .
indication 0

Logger name,
model, version, se-
rial number

Channel  .
indication 1

Channel  .
indication 13

Menu 2
Select channel..

Menu 3
show info..

Menu 4
Show last se-
lected view..

Record stop?

Recording is 
stopped.

Timeout TimeoutTimeoutTimeout

Menu 1
Select predefined 
groups..

Group indication 1

Group indication 2

Group indication 3

Group indication 4

T1 T1 T1 T1

T1

Last group 
indication or 
channel indication

Display turned off 
through timeout 

Timeout

Channel  .
indication 14

T1

T1

T1

T1

T1

T1

T1

T1

T1

T1

T1
T1 T2

T2 T2

T2

T2

T2

T2

T2

T2

T2

T2

T2

T2

T2

T2

T2

*

*

* For defining group indication and channel indication see „Defining the logger 
display“ on page 36.
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Indicator LED’s
 

Information displayed
LED Meaning

 Red Alarm limit reached

 Blue Define the behaviour of the blue LED via Setup > Ba-
sic settings. See the section Setup, LED behaviour. 

Meaning of the yellow lamp during charging 
LED Meaning

	 	 yellow 
		  continuously

Charging in progress

	 	 yellow off •	Fully charged
•	No connection to PC
•	PC turned off
•	Power supply not connected

	 	 yellow flashes Fully charged 

The battery is recharged for a short time, e.g. during 
an online measurement or data recording
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Maintenance

User checks
•	Check the logger before each use. 
•	Before using the logger check for visible signs of damage.
•	Check the functions of the logger.
•	Never use a logger that is damaged or not functioning perfectly.  Never use  .

damaged accessories.
•	Ensure that the battery is sufficiently charged for the required period of use.	
Should the logger not function perfectly or should damage become apparent 
send the unit to MSR Electronics GmbH for repair. Repairs may only be carried 
out by MSR Electronics GmbH or an authorised dealer. Defective or damaged 
components may only be replaced with manufacturer’s original parts.

Cleaning

CAUTION
•	Ensure that no fluids enter the logger's casing. 

Fluids will cause corrosion damage and short 
circuits.

•	Never use corrosive or abrasive cleaning agents or polishes.
•	Cleaning agents containing additives such as alcohol will cause the case to 

become matt and/or brittle.

•	 Clean the logger when necessary.
•	 Always disconnect the logger from the PC or the power supply before clean-

ing.
•	 Use a cleaning agent suitable for plastic or a cloth dampened with water and 

soap.

Charging the battery
Before first use:	 The battery is not fully charged on delivery and should 

be charged before using the logger for the first time. 

Charge the logger	 •	Before each use
	 •	At least every six months
Procedure:

•	Connect the logger to the power supply or via USB connection cable to the PC 
or an external USB mains adapter.

Notes:	
•	The meaning of the yellow warning light during charging is described on page 12.
•	Charging an exhausted battery takes approx. 5 hours using the mains adapter. 

Charging is also possible via the USB port with the backlight turned off (ap-
prox. 28 hours).

•	Recorded data is non-volatile and remains in the unit’s memory even when the 
battery is exhausted.

•	Never store the logger with a discharged battery. See ->15 (storage conditions).
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Specifications

See data sheets

Defining the axes

-Y

-Z

Z

Y

-X

X
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Operating, transport and storage conditions

•	 Protect the logger from excessive exposure to the sun and other sources of 
heat. Avoid heavy impacts.

•	 Do not place heavy objects on top of the logger.
•	 Only store the logger in a dry, dust-free environment.

Operating conditions: 
Temperature:		  -20°C to +65 °C
 .
Pressure:		  500 mbar to 2500 mbar absolute
 .
Humidity:		  10-95 % relative humidity, non-condensing .
		  Avoid contact with water and humidity

Optimal storage and transportation conditions:

 
Temperature:		  5 °C bis 45 °C (ideal storage condition for the battery) .
	  .
Humidity:		  10-95 % relative humidity, non-condensing .
		  Avoid contact with water and humidity .
 .
Battery charge level:		  Never store the logger with a discharged battery. 	
		  The ideal charge level is a 2/3 charge .
		  (see „Charging the battery“ on page 13)

Troubleshooting

Problem Possible cause Possible solution
The temperature 
increases con-
tinuously when 
the logger is 
connected to the 
mains adapter or 
the PC

The battery warms up 
because charging com-
mences.

When making temperature 
measurements disconnect 
the logger from mains adapter 
or the PC.

The PC programs 
do not recognise 
the connected 
logger

The COM port driver is not 
installed correctly.

Observe the manufacturer’s 
installation instructions. 
http://www.ftdichip.com/

http://www.ftdichip.com/
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•	MSR 255
•	CD including:
	 • User manual	

• Logger PC software
•	Logger USB connection cable
•	Mains adapter
•	Terminal assignment

Disposal

Take the logger and the mains adapter to a municipal waste disposal 
centre or return it to MSR Electronics GmbH The logger and the mains 
adapter must not be disposed of in normal domestic waste.

Packing list

Declaration of conformity



 

 

 

 Setup

Online

Viewer

Reader

PC software
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Overview

External processing of logger data is carried out using the PC programs Setup, 
Reader, Viewer and Online. The PC programs can be used for all logger types.
The Setup enables the properties of the logger to be customised to user’s re-
quirements.
The Reader allows the user to transfer measurement parameters to a Windows 
PC. The Viewer is used to display data graphically or in table form or to export it 
as a text file (*.csv).
With the help of Online (and the built-in display) users can view measurement 
parameters and curves “live” on a PC. 

Installation of the PC software on a PC

For installation you will require Windows administrator rights. 

Insert the CD containing the PC software into the computer’s CD-ROM drive. The 
installation procedure starts automatically*. 

Completing installation 

Initial installation: Select 
Install USB driver.

Click on Finish.

The logger symbol appears on screen.

If the PC is not set up for automatic installation, proceed as follows:

1.	Click Start > Run
2.	Click Find > Look in: (set to CD drive). 
3.	Select the file Install_MSR.exe and Open.
4.	In the Run dialog box click OK.
5.	The installation process will begin. 
6.	Follow the instructions and select: Run Program now.
7.	During the initial installation select Install USB driver. See above, Complet-

ing installation.

PC software

*	The program "Inno Setup" for installing the logger PC programs was written by Jordan Russell (www.jrsoftware.org, copyright Jordan 
Russell).

www.jrsoftware.org
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Version number of CD 

Version numbers of PC programs 

Logger program window

Starting the logger Software

The logger software may be started by clicking on the logger symbol  or via 
Start > Programs > MSR (folder) > MSR. The logger program window appears:
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Uninstalling

The software is uninstalled via the computer’s operating system (Programs > 
MSR > Uninstall MSR).

System Requirements

•	Windows 2000 / XP / Vista / 7
•	USB port
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Preparation

Before using the PC programs Setup, Reader and Online, the following prepa-
rations must be completed:

•	Use the USB connecting cable to connect the logger with the PC.

•	Before first use: Using logger symbol open the logger program window, select 
Settings > Logger. 

•	Select the rule by which the Setup, Reader and Online programs are to search 
for the required logger*.

 

•	Enter the path to the  .
directory.

•	See following page for 
template

•	Select the required 
language. 

•	Customer-specific 
programs

Logger program window

*	One of the following windows will appear if a connection to a logger cannot be 
established using the current rule. .

During Setup:

Loader Dialog Starts the  .
Setup demo mode

Starts the
Loader dialog
(see screenshot left)
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Template

The template, selected via Setting > MSR 255 (*.mse), defines which sen-
sors the Reader reads out as standard or are displayed in Online. The 
template sets the colour of the trace, the positioning of its axis (left, right) 
and gives the sensors a name (“HUM, T1” is required to be displayed as 
“outside temperature”, for example). Templates can be produced on the 
basis of examples contained in Viewer (->34).

	 Example
	 The temperature curves are required to be blue and oriented on the right 

hand axis in all display modes.

1.	Assign right hand axis and blue colour shades to temperature in Viewer.
2.	Save as template (Bluetemp.mse).

3.	Generate new templates for Reader and Online: Select logger program 
window, Settings MSR 255 > Template  , enter new name and path 
(Temperature.mse), then Open.

4.	Open the still blank template (Temperature.mse) using . 

5.	Import the template that was created in Viewer (Bluetemp.mse). 
Select the required sensors (tick in checkbox) in the Module column and 
confirm with Accept. 

6.	Edit the displayed list: First select a sensor in the Module column and 
then choose Edit. 

7.	Change the name “HUM, T1” to “Outside temperature”, and Accept.

8.	Continue to make the necessary adjustments and confirm them with Accept.
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Once the data has been transferred to the PC vari-
ous options are available to the user. Details may be 
found in the text window.

Example: "Automatically generate a text file" 
In addition to the logger format file, the Reader cre-
ates a text file (*.csv), which can be opened with pro-
grams such as e.g. Microsoft Word or Excel. 

User defines which 
records are transferred 
to the PC, their filenames 
and their location.

Transfer only the most 
recent data record logged 
with the logger to the PC. 

User defines which 
records are transferred to 
the PC

Pre-adjustments - Reader

Enter the required options for the Reader** via Settings > Reader. 

**Data records are transferred from the logger to a PC using the Reader.

Once data transfer is complete the Reader creates a data record (*.msr) from each 
logged record, names it and saves it in the corresponding directory. The bottom-
most option allows the user to alter the suggested filename and location.
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Pre-adjustments - Online 

Note 	 The functions described on this page are currently not available with 
this logger.

Completion of the preparatory measures

Upon exiting Settings the PC saves the settings that were last entered.

Once entry of the settings is complete, select Programs and start the required 
program.

Note: 	 The following instructions assume that the preparations for using the 
PC programs have been completed.
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Setup is used to select the sensors for which the logger is required to save 
measurement parameters, to enter the measurement frequency and to set the 
behaviour of the logger’s memory. In Setup you can also define the start time for 
data recording and stop data recording. 

The following subjects are dealt with in the Setup chapter:

Basic settings   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   26 
Prediction   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   27
Reducing the volume of data  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .     28
Conditional recording of measurement parameters (limits)   .   .   .   .   .   .   .   .   .   .     28
Setting the alarm limit   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  28
LED behaviour   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 29
Transferring basic settings to several loggers  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .     39 

User settings   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  30
Adjusting the channel properties  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 31
Change basic parameter  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .     33
Calibrating the sensors  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 34
Change display parameter  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 35
Defining the logger display  .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   . 36
Formatting the memory   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .   .  36

Setup
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Basic settings

This page describes the most commonly used settings – the Basic settings. 
Information on further settings can be found on the following pages.

•	Complete the preparations (->30).
•	Start Setup (Setup symbol).
•	Edit the Basic settings according to your requirements.
•	Transfer the new configuration and the start conditions to the logger with Write 

basic settings.

Define the sensors from which the logger should record data, together with the storage 
rate.
The 50Hz (3200 Hz) function is only available for the acceleration sensors (ACC).

50 Hz (3200 Hz)
Acceleration values are measured at 3,200 Hz and saved at a frequency of approx. 
50 Hz following digital filtration. Energy consumption increases for 50Hz (3200 Hz) 
measurements.

Exit setup

Read the information 
and measurement 
parameters 

Freezes the selected 
options in the Basic 
settings and Limits 
tabs so that these 
can be transferred to 
other logger units ->29

Currently no data is being recorded (inactive)
(active: data recording in progress)

Name of the 
logger ->30

Overwrite oldest 
measurement param-
eters when memory 
is full

Transfers the configuration, the start condi-
tions and the PC time to the logger 

Stop data recording

Conditional record-
ing of measurement 
parameters ->28

->30
->30

Blue LED flashes during data re-
cording ( ->29)

->37
->36

Enter the main
storage rates
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Prediction
The maximum amount of data that can be re-
corded is influenced by:
•	The number of sensors
•	The measurement rate 
•	The battery capacity

With each click on Prediction (Basic settings) the program generates an ap-
proximate prediction using the selected basic settings.

Note: The Limit settings are not taken into account here.
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Reducing the volume of data
When making extensive recordings it is recommended that all sensors that are 
not required be “turned off”. This prevents unrequired measurement parameters 
from being saved. 

•	Under Basic settings turn "off" all unused sensor groups (see next section).
•	To turn off individual sensors within one sensor group proceed as follows: Set 

the cut-in condition such that they are not activated during the planned re-
cording (e.g. > 200 °C) (see next section).

Conditional recording of measurement parameters (limits)

If for example, you require only to record temperatures above 5°C and less than 
20 °C, use the following procedure:

Setting the alarm limit
The logger can display an alarm if a certain measurement parameter drops below 
or exceeds a certain value. When the alarm condition occurs the red LED flashes 
once per second until the data recording is stopped.
Inputting the alarm condition is carried out in the same way as setting the cut-in 
conditions (see section Conditional recording of measurement parameters).

In the Alarm Limit, Limit L1 and Limit L2 columns enter the 
alarm conditions.
The alarm limits can be displayed in Viewer.

•	In the columns Record Limit, Limit 
L1 and Limit L2 enter the cut-in condi-
tions for the sensor.

•	Return to the Basic settings with 
 and click Write basic set-

tings. The limits will only be trans-
ferred to the logger with Write basic 
settings.

•	Activate Limits active 1 and the cor-
responding temperature sensor 2. 

•	The Limits tab opens.

The logger only records measurement 
parameters from the sensor T(p) above 
5°C and less than 20 °C

S
e

tu
p

•	1

•	 2
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LED behaviour

The behaviour of the blue LED is defined via Setup > Basic settings.

Situation Behaviour of the blue LED

Start time has 
been transferred 
to the logger

First  .
5 seconds

Double-flashes 5 times at 1-second  .
intervals

Waiting for 
start Double-flashes at 5-second intervals

Data recording in 
progress

First  .
5 seconds Flashes 5 times at 1-second intervals

After 5 sec-
onds

LED flashes with
main storage rate t1 LED does not flash

Transferring basic settings to several loggers

Use the following procedure to transfer basic settings that have already been 
input to several loggers: 
•	 Start Setup.
•	 Connect the logger to the PC. (If several loggers are connected to the PC, 

select the COM port of the required logger)
•	 Enter the required values in the Basic settings tab. 
•	 Set the cut-in and alarm conditions in the Limits tab.
•	 Use Write basic settings to transfer the basic settings to the logger.
•	 Disconnect the logger just configured and connect the next logger to the PC.
•	 Select the new logger via COM Port.
•	 Caution! If you wish to import the information and measurement parameters 

of the newly connected logger, you must first select the option Freeze ->24, 
so that the settings in the Basic settings and Limits tabs are not overwritten!

•	 Transfer the basic settings to the logger with Write basic settings.

Note:	
•	 It is also possible to configure differently equipped loggers with a single basic 

setting. One logger may for example, not be equipped with any analogue in-
puts. The setup program then simply does not write any data to the settings 
saved in the logger for those analogue inputs.

•	 If a connected logger deviates too greatly from the first logger, this message 
appears: 
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Enter the name 
of the logger

Enter date of last calibration 
and comment

Check the checkbox in order to enter/change the date, notes 
and „Calibrating the sensors“ on page 34.

Only for analogue inputs: Input of a "warm-up time" to warm-up 
analogue sensors before making measurements. A start-up time 
of zero = the sensor voltage is always ON.

1

2

User settings
To display the configuration saved in the logger select the Basic settings tab 1 
and click Read basic settings. The settings are now displayed in the User set-
tings tab. 

CAUTION
The changes made in the User settings tab 
and its sub-menus will only be transferred to 
the logger after clicking Write user settings 2.
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Adjusting the channel properties

Select the tab Channels 3 in order to change the name, unit, display format and 
calibration of a channel. 

The following options are available (see following schematic):

•	Change basic parameter (see page 33)
Changing the factory settings (name, unit, display format).  .
This information is used for calibration purposes among others.  .

•	Calibration (see page 34) 
Correction of the displayed values. .

•	Change display parameter (see page 35)
Change the factory settings or the information entered under Change basic 
parameter. 
This information is used for the logger and PC display.
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Use
calibration

User information
Basic unit

User information  
Display unit

Logger and PC display

User information

Name
Unit
Display format

Yb = Gb * X + Ob

Factory settings
 .

Name
Unit
Display format

Yb=X

Ys=Yb

Ya=Ys

Ys=Gs * Yb+Gs

User information

Name
Unit
Display format

Ya = Ga * Ys + Oa







Ya

X Measurement value  

Gb Base amplification

Ob Zero reference point

Yb Reference value

Yb Reference value

Px Calibration points  (P1 and P2)

Gs = (P2Setpoint value -P1Setpoint value )/(P2Actual value -P1Actual value )

Os = P1Setpoint value – Gs * P1Actual value 

Ys Calibrated value

Ys Calibrated value

Ga Display gain

Oa Zero point display

Ya Display value

Ys

Yb

Measurement value X
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Change basic parameter

Change basic parameter is used to adapt the factory settings (name, unit, 
display format) to your requirements. These details are used among others, for 
calibration purposes.

Select the desired channel (e.g. analogue input A2) and then click Change ba-
sic parameter. Enter your adjustments 5 (e.g. Mbar instead of Volt). 

To enter the conversion factor (e.g. Volts to Mbar) the following options are avail-
able:
•	Enter the amplification and the zero point
•	Using the calculation assistant 6 enter the values for points P1 and P2 7. 

The program will then calculate the amplification and the zero point.

Activate Apply user information by checking the checkbox 4 and then click 
OK. Transfer the changes to the logger by clicking Write user settings.

Note: Should you wish to use a different display unit to that used for calibration, 
then please use the function Change display parameter.

3

4

6

6

Max. 4 characters

Changes have been made to this channel.

7

5

Resetting channel properties to the factory settings: 
Uncheck checkbox 4 (Apply user information) and transfer the changes to the 
logger by clicking Write user settings.
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Calibrating the sensors 

The sensors and analogue inputs can be calibrated using a 2 point calibration 
process.  Those sensors marked “not changeable” in the Calibration column 
cannot be calibrated.

Select User settings and at the bottom click on Read user settings. Under 
General > Calibration, check the Change values checkbox.
Choose Channel 3. 
Select a channel and then click Calibration.

3

4

Calibration can be carried out a) manually or b) by measuring the signal and sub-
sequently entering the target value.

a) Manual calibration
First enter the actual value and then the associated target value for points P1 and 
P2.  Activate the completed calibration by checking the checkbox 4.  Confirm 
your selection with OK.

b) Calibration using the measurement function

Apply the desired signal for point P1 and click Measure. The 
measured actual value is displayed. Enter the associated tar-
get value for point P1. Repeat this procedure for P2. Activate 
the completed calibration by checking the checkbox 4. Con-
firm your selection with OK.

Activate the completed calibration by checking the checkbox 4 and then click 
OK. If necessary, calibrate further sensors (channels). With Write user settings 
2 you can simultaneously transfer all of the completed calibrations to the logger.
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Resetting the calibration to the factory defaults
Uncheck the checkbox 4 (Apply calibration) and transfer the change to the logger 
by clicking Write user settings.

CAUTION
If, following calibration, changes are made via 
„Change basic parameter“ on page 33, the per-
formed calibration will be lost.

Change display parameter

Changes that are made with Change display parameter have no effect on the 
settings made with Change basic parameter. This allows you to always perform 
calibration using the units selected with Change basic parameter.

Select the desired channel (e.g. analogue input A2) and then click Change dis-
play parameter. Enter your adjustments 5  (e.g. psi instead of Mbar). 

To enter the conversion factor (e.g. Mbar to psi) the following options are available:
•	Enter the amplification and the zero point
•	Using the calculation assistant 6 enter the values for points P1 and P2 7. The 

program will then calculate the amplification and the zero point.

Activate “Apply user information” by checking the checkbox 4 and then click  
OK. Transfer the changes to the logger by clicking Write user settings.

3

4

6

6

Max. 4 characters

7

5

Resetting the properties to the factory settings: 
Uncheck checkbox 4 (Apply user information) and transfer the changes to the 
logger by clicking Write user settings 2. 
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Defining the logger display

Select Display and then click Read user settings at the bottom.

Define what the device should display following a power-on-reset under Start-
up. A group of measurement parameters 1 defined under Group indication, or 
a single channel 2 can be displayed.

1

2

Transfer the desired settings to the device by clicking Write user settings.

Defining the group indication
Define which channels should be displayed together in one group indication un-
der Display > Group indication. 4 group indications each with 4 channels can 
be shown. For each channel, the measurement parameter, limit L1 or limit L2 can 
be displayed.

Transfer the desired settings to the 
device by clicking Write user set-
tings.

Open group indication on the de-
vice: See „Logger display and log-
ger operation“ on page 11.
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Deletes all measurement parameters saved in the logger

Formatting the memory

CAUTION Formtting will erase all measurement param-
eters saved in the logger!

Formatting is used to delete all the measurement parameters saved in the log-
ger. 

Formatting the logger is carried out from the Format memory tab.
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With the Reader users can selectively transfer data records logged with the log-
ger to a PC. It does however free measurement records that have already been 
read out for overwriting.

Transferring data records to a PC
•	Complete the preparations (->21) aus.

•	Start the Reader (Reader symbol)

CAUTION
Once data transfer has started (Start) all data 
records saved on the logger can be over- .
written if required, even if the circular buffer is deac-
tivated in Setup.

	
•	Begin data transfer with Start. 

The options selected under Settings > Reader (->23) influence the next steps:

•	Under the option Read selected records the following data entry dialog box 
appears: 

•	 Select the data records 
to be transferred. 

•	 Click OK.

•	 Data records having 
the same start time are 

	 written together to
	 one file.

•	With the option Read selected records and save with “Save dialog as” 
under Settings > Reader (->23) the filenames and locations suggested by 
Reader can be overwritten.

Once the data records have been saved on the PC a list of files created appears.

Date (YYMMDD) 
Serial number

Recording start time (HHMMSS)     Copy number

Filenames allocated by the 
Reader

Reader
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Viewer
Records created in Reader or Online may be viewed and edited on a PC with 
the Viewer. The measurement parameters may be displayed either in graph or 
in table form.

•	Start the Viewer (Viewer symbol).

•	Open a record (*.msr) via File > Open. 

Traces on / off

Cross-hair on / off

Lock axis Autoscaling

Undo last change

Switch between graphs, 
tables and configuration 

X and Y values:  
Cross-hair 1, cross-hair 2
(The displayed Y value always 
relates to the left-hand axis)

X-axis = time
(seconds)

Difference between 
cross-hairs 1 & 2

Gridlines

Text mode

Shift between 
text tool and 
graphics mode 

Text created 
using the text 
mode

Alarm limit

Alarm limit exceedDisplayed as a table
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Move traces	 With right mouse button held down

Enlarge section	 Mark the required section with the left mouse 
button held down. See also Graphics > Fixed 
axis).

Cross-hair	 Move axis: 	 Grab the axis, move with left mouse button.
	 Move centre:	 Grab the centre, move with left mouse button.
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File
The File menu is used to Open records , to 
Reopen (Open again) the most recently used records 
and to Save the currently open record as displayed .

With Save time window as the measurement pa-
rameters of the displayed time window are saved. 
(The measurement parameters of the hidden traces 
are also saved). For further options see Cutter ->44.

Templates help to standardise the displays, enable 
easy repetition when reselecting the same sensors 
and the same printing format.

Creating templates: Adjust the display with Graph 
and Configuration  and save via File > Save as 
template (file type: *.mse).

Apply a template to the displayed record: 
File > Use template then select the required tem-
plate (*mse).

Export Time window as text exports the meas-
urement parameters of the displayed time window 
in *.csv format. The measurement parameters of the 
hidden traces are also exported.

The trace can be exported in Bitmap (*. bmp) or as 
JPEG forma.

Print preview opens a preview of the trace/graph. 

Print  opens the print dialog box.

Exit closes the Viewer.  If changes were made the 
user is asked whether the changes should be saved. 

Note: 	
The program saves changes as “Template”  .
(*. mse). The template is automatically saved in the 
record’s directory.  Template (*.  mse) and record  .
(*. msr) have the same name.
Upon Opening a record the Viewer searches for 
the template associated with that record. Should the 
template not be located in the same directory as the 
record then the standard format will be opened. 
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View, Graph ,Table, Configuration 

Graph
Gridlines can be shown for each axis (bottom, left, 
right).

Fixed axis simplifies the amount of detail shown 
within a time window or range of values.

•	Select the required section with the left mouse but-
ton held down. The section is displayed enlarged.

•	For closer viewing, lock the time window ( ) or 
range of values to the left or right axis ( / ). Sev-
eral axes can be locked. 

•	With the left mouse button held down, select the 
required detail. The enlargement is displayed with-
out altering the time segment or range of values of 
the locked axes.

A further click releases the lock. 
Auto scal  clears all locked axes.

Calculation functions

Using the two Crosshairs values can be measured 
on the X and Y traces. X and Y differences can be 
evaluated with the second cross-hair. The Y values 
displayed are always associated with the left axis.

With Detailed legend traces can be turned on and 
off in the list of sensors.

If available: Display of the alarm limits (see ->39). 

The complete record is displayed by selecting  .
Auto scale . 
Auto scale  clears all locked axes.

Undo  undoes the last enlargement.  As long as 
the Configuration dialog  is not quitted, Undo  
allows the last changes made to the displayed con-
figuration screen to be undone.
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Table (Tabelle)
Go to time  allows users to jump straight to the 
line in the table with the required time.

Jump to beginning of graph  causes the table 
to jump to the first measurement values displayed 
in the graph.

Configuration 
As long as the Configuration  dialog is not quit-
ted, Undo  allows the last changes made to the 
configuration screen to be undone.

Text mode
Using the text mode you can insert texts at any 
place.
By clicking on  you can activate and deactivate 
the text mode.

Insert text:
•	Click on .  The viewer displays 

"Text 1" in the upper left corner.
•	Drag the text field to the desired 

place.
•	Double click on the text field and 

enter your required text.

Delete text:
•	Click with the right mouse button 

on the text field and select Delete.
Text field with X and Y values:

•	place the crosshairs on your cho-
sen position to adoddopt the X and 
Y values you would like to use in 
the text field.

•	Create a text field (see above) and 
click on the right mouse button. 

	 Select the desired representation.
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can be annotated, the time segment to be displayed 
can be set, and the Increment for the lettering and  .
ruled lines, together with the Format for numbers 
can be entered. 
Automatic axis annotation with an Increment of 0 
(zero).

The number Format for the displayed X and Y values 
is entered via Configuration  > Crosshairs.
The displayed Y value always relates to the left axis. 

As long as Configuration is not quitted, users can 
undo the last changes made to the displayed con-
figuration screen with .

Quit Configuration  via Graph  or Table . 
Upon quitting, the Viewer saves the configuration.

Undo the last changes

Quit Configuration  

Configuration  allows the display method of the 
measurement parameters to be set with the help of 
the configuration screens. 

Entering title and footer information is achieved via 
Configuration  > General.

The associated sensor name, assignment to the left 
or right axis, the colour, line weight and style can be 
set for each curve.

Axis > inactive allows the graph curve to be shown 
or hidden as required.

CAUTION

Depiction of the curves using dots (Configuration 
 > Curves > Dot: Yes) requires more computing 

power, possibly leading to problems.
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Online allows users to view the progress of the measurement parameters  .
directly on-screen.

Procedure:
•	Complete the preparations ->21. 
•	Start Online (Online symbol)

Online

Turn trace on and off

Exits Online

Stop: A display
Continue: Continue

The logger is current-
ly recording meas-
urement parameters

•	Online displays the measurement parameters graphically and numerically.

•	Select the sensors that you wish 
to display.

•	Click on Next.
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For recurring applications in Online, Templates assist in se-
lecting the required sensors and adjusting the display to suit.

Create template: Start Online and select the required sen-
sors. Select Next>. Use 
Graph > Properties, 
Graph > Grid line, 
Graph > Legend and 
Graph > Start time to change the way the curve is dis-
played. Via Back return to the trace display. Interrupt record-
ing with Stop. Save the template via File > Save as tem-
plate.

Apply the template to Online: File > Use template and 
select the required template (*mse).

Once recording has finished by clicking on Stop, the recorded 
measurement parameters can be saved via File > Save as.

		

In the menu View the measurement parameters can be dis-
played as curves with Graph or as numerical values with 
Monitor. The font displayed on the monitor can be selected 
via the menu Monitor > Font.

Once recording has finished by clicking on Stop, the record-
ed measurement parameters and traces can be deleted via 
Clear.

		  The display can be changed via Properties, Gridlines, Leg-
end and Start time.

		  Select the frequency (Refresh rate) with which measurement 
parameters are to be transferred to the PC.

		  In the Time window you can define the time period repre-
sented by the time axis.
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The CSV utility creates text files (*.csv or * .fmc) from data records (*.msr). Files 
saved in *.csv format can subsequently be opened and edited in a word process-
ing or spreadsheet application. The *.fmc files can be transferred to FreeMat1.

Creating a text file
•	Start CSV (Logger Program window > Tools > Csv).

•	Select the output format (standard *.csv or 
FreeMat * .fmc)

•	Click on Start and select the data record from which 
the text file is to be created. CSV creates a text file 
(*.csv) and saves it in the corresponding directory 
for that data record. Text file (*.csv) and data record 
(*.msr) have the same name.

Note on creating *.csv files: If a template (*.mse) exists for the data record in ques-
tion, CSV takes this into account when creating the text file (*.csv).

Example: Opening a CSV text file with Excel
•	Start the word-processing or spreadsheet program.
•	Open the CSV file via File > Open. 
•	Under File type, select Text Files

CSV

Excel file with measured data

Data source

Logger name 

Serial number 
Logger revision number

Record start time: Date (Day.Month.Year) and 
time of day (Hr:Min:Sec) 

Modules for which measurement parameters 
were recorded 

Module version

Time difference between PC time and  .
Logger time (readout time)

Channel and sensor names 

Unit for the displayed value 

Measured parameters (data) in
chronological order .

Time of recording

1 Further details on FreeMat can be found in the section FreeMat ->56

C
S

V
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The Cutter utility creates an extract from a data record (*.msr). 

Creating an extract from a data record
•	Start the Cutter utility (Logger Program window > Tool > Cutter)

•	Click on Start and select the data record from 
which the extract is to be created. 

•	Select the time window. Beginning / End.

•	Select the sensors for which the measurement 
parameters are to be exported to a new data  .
record and click Next.

•	Enter the name and directory for the new data  .
record. Click on Save.

Cutter

C
u

tt
e

r
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Calc
With Calc curves from existing data records can be linked to each other using 
formulae and saved as a data record (*.msr). The saved data record can be dis-
played and processed in the form of curves or as a table using the Viewer. Tem-
plates simplify the processing of recurring tasks. 

Note:	 For making comprehensive calculations the FreeMat math software is 
available (see ->56).

Computing new curves
•	Start Calc (Logger program window > Tools > Calc)

1  	Open data record (data origin)
	 Click on Open to open the data record for which you want to perform calcu-

lations on the curve. It is possible to open multiple data records.

2 	 Create new curves
	 From imported curves select the curve that you want to use for your calcu-

lations and drag it – with the left mouse button pressed – to the right into the 
field for curves to be plotted. Repeat this procedure until the required number 
of curves is shown on the right.

3  	Enter formula
	 Enter the formula to be used for the new curve into the Formula column. For 

this, use the capital letters on the left.
	 Example for a subtraction: A-C

	 You will find a list of the available functions at the end of this section or under 
Help.

	 Modify the text for the new curves
	 The entries in the columns Module, Sensor and Unit can be modified.

Open 
data 
record

Enter formulaNumber field

1

2

34
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Modify the order of the new curves
With the left mouse button pressed, drag the number field to 
the required position.

Delete new curves
Click inside the number field of the curve to be deleted and 
then press the delete key. Via Template > Delete plotted 
curve, all new curves can be simultaneously deleted.

                    4  	 Calculating and saving the new curves
Click on Calculate then enter the name and set the directory 
for the new data record. Click on Save.

	 Note:	 The curves are saved as data records (*.mrs).  The saved 
measurement parameters can be displayed and processed 
as a curve or as a table by the Viewer. Intermediate values are 
interpolated.

		  Only curves that overlap timewise can be calculated.

Creating a template for processing recurring tasks
Once you have created the new curves you can save their la-
bels and formulae as a template (*.mse). (Template > Write).

Creating new curves using templates
Open the required template (*mse) via Template > Read. 
This will automatically generate a number of new curves.
Multiple templates may be used to generate new curves. 
Each template generates a number of new curves. 
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Operators / brackets

+  -  *  /   ^ Plus, minus, multiply, divide, to the power of

(  ) Open brackets, close brackets

Functions

sqrt(no.) Square root of the number

ln(no.) Natural logarithm of the number (base e)

exp(no.) Raise basis e to the power of the number

abs(no.) Absolute value of the number

sgn(no.) no. >0: sgn = 1 
no. =0: sgn = 0 
no. <0: sgn = -1 

cos(no.) Cosine of the number

sin(no.) Sine of the number

tan(no.) Tangent of the number

ctg(no.) Cotangent of the number

arcsin(no.) Arc sine of the number

arccos(no.) Arc cosine of the number

arctan(no.) Arc tangent of the number

arcctan(no.) Arc cotangent of the number

sinh(no.) Hyperbolic sine of the number

cosh(no.) Hyperbolic cosine of the number

tangh(no.) Hyperbolic tangent of the number

ctgh(no.) Hyperbolic cotangent of the number

toggleSgn(no.) Changes every second measurement parameter sign 
(plus/minus)

Further functions on request
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Concat
With Concat (concatenate = to link) data records can be linked together and 
saved as a new data record (*.msr). The newly created data record can be dis-
played and processed in the form of curves or as a table using the Viewer. 

Concatenating several data records
Start Concat (Logger program window > Tools > Concat)

1

1  	Select the data records to be concatenated
	 Open the data records that you want to concatenate by clicking Add. Note 

that the list must be in chronological order such that the oldest data record 
is at the top. Therefore either open the oldest data record first or sort the list 
afterwards (see below). 

	 Sort the list alphabetically
	 Use Sort to sort the list alphabetically.
	 Data records that have automatically generated filenames (->38) can be 

chronologically sorted using Sort.
	
	 Modify the data record order
	 With the left mouse button pressed, drag the number field to the required 

position.

List of data records to be concatenated

2

3

Status window

Before concatenation After concatenation

Number window

Data
record 1

p 

TimeT2 T1 T0 

Data
record 2

New Data record 3
p 

TimeT2 T1 T0 
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	 Delete all data records from the list
	 Use Delete all to remove all data records from the list. 

	 Delete one data record from the list
	 Select the data record to be deleted and click Delete line. 

2 	 Enter the name and directory for the new data record
	 Set the path to the directory using Browse and enter the filename, or use 

the input window to do this.

3 	 Calculating the new data record
	 Start the calculation process with Start. Cancel the calculation with Stop.

Note: 		
•	Concat creates a straight line between the last 

data record of the first curve (T1) and the first data 
record of the second curve (T2).

 .

•	If, for the data records to be concatenated, there 
are curves that overlap timewise and these have 
the same name (same module and sensor names 
with the same units), the calculation will be aborted 
and a corresponding message* will appear in the 
status window.

•	If the module names, sen-
sor names or units of the 
curves to be concatenated 
do not correspond Concat 
will be unable to join the 
curves and will create two 
curves.**

•	With Concat you can  .
superimpose curves with 
different module or sensor 
names.

*	Remove overlap
	 Use the Cut utility to create an excerpt from a 

data record that does not overlap timewise with 
the next data record.

**	Modify module names, sensor names and units
	 Use the Calc utility to match the module names, sensor names and units for 

the curves.

p 
p1 p1 

TimeOverlapping

p 

TimeNew data record 

Sensor p1 Sensor p2 
p 

Time

Sensor p1 Sensor p2 

Different sensor 
names

p 

TimeNew data record 

p 

TimeDifferent sensor 
names and 
start times

p 
p1 p1 

TimeRemove overlap

New data record 3
p 

TimeT2 T1 T0 
Straight line created by Concat
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FreeMat is open source math software that can be installed from the logger CD  
(ADDITIONAL\FREEMAT).  FreeMat can be used to carry out a wide variety of 
calculations.

How are data records transferred to FreeMat?
The Reader transfers the data recorded with the logger (records) to the PC. From 
these data records (*.msr) CSV creates FreeMat files (*.fmc). Using the scripts 
included these can be opened and edited in FreeMat.

More information on FreeMat can be found at 
http://freemat.sourceforge.net/index.html.

FreeMat 

The following FreeMat scripts can be found on the  logger CD under ADDITION-
AL\FREEMAT\MSCRIPTS:

plotmsr.m	 Imports *.fmc files into the FreeMat environment and 
presents the data records graphically.

loadmsr.m	 Imports *.fmc files into the FreeMat environment.

http://freemat.sourceforge.net/index.html
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